10 de diciembre de 2007

Combinar BUSCARV y COINCIDIR

Como ya somos expertos en el uso de BUSCARV I, II y III, estamos en la posibilidad de empezar a usarla en combinación con otras funciones, por ejemplo, COINCIDIR.

COINCIDIR nos devuelve la posición de determinado valor dentro determinado rango (matriz) de datos, contando de izquierda a derecha o de arriba a abajo, comenzando en 1. Dicho rango o matriz de datos debe ser unidimensional, es decir, de una sola fila o de una sola columna. La sintaxis es:

COINCIDIR(valor_buscado,matriz_buscada,tipo_de_coincidencia)

En el siguiente ejemplo:


utilizamos la función para saber el turno de atención de un grupo de pacientes de un neurocirujano. La fórmula en E2 es: =COINCIDIR(E1,A2:A11,0)

Si seleccionamos un rango de más de una fila o columna, obtendremos el resultado de error #N/A. Forzosamente nuestro rango de búsqueda debe ser unidimensional. El último argumento, tipo_de_coincidencia, indica a Excel si debe buscar una coincidencia exacta o aproximada.

Retomando nuestro tema, consideremos el siguiente resumen de gastos:

Si queremos conocer lo que gastamos en teléfono en febrero de 2006, escribiremos esta fórmula, digamos que en B4:

=BUSCARV("telefono",A7:G19,3,FALSO)

Si queremos la cantidad de marzo, modificaremos la fórmula de esta manera:

=BUSCARV("telefono",A7:G19,4,FALSO)

Como no resulta práctico el estar modificando una y otra vez una fórmula hacemos las siguientes modificaciones a nuestro modelo:

Creamos en B3 una lista desplegable utilizando Datos - Validación... - Lista, con los encabezados de mes como argumentos:

Luego, en nuestra fórmula de B4, modificamos el tercer argumento de BUSCARV (columna) y lo formulamos utilizando COINCIDIR y la celda B3:


La fórmula de B4 es:

=BUSCARV("telefono", A7:G19, COINCIDIR(B3,B6:G6,0)+1, FALSO)

Ahora, para saber lo gastado en telefono en cada mes simplemente lo seleccionamos de la lista.

Por último, creamos otra lista desplegable en A4 utilizando los conceptos de gasto como argumentos de la lista. En la fórmula, sustituimos "telefono" por A4. De esta manera obtenemos una lista cruzada de valores "dinámica":

9 comentarios:

  1. Hola, muy buena explicacion, gracias por compartir, pero tengo una duda en caso que se tenga doble o triple pago en cuanto a Telefono en un mismo mes (supongo esto por q me sirve para lo que yo necesito hacer), que formula puedo utilizar para que me de los 2 o 3 pagos de Telefono en ese mismo mes y no me limite a uno solo como lo es con BUSCARV. Saludos

    ResponderEliminar
  2. Me ayudaste a salir de un apuro, gracias

    ResponderEliminar
  3. Me ayudaste a salir de un apuro, gracias

    ResponderEliminar
  4. porq en la formula agregas +1?

    ResponderEliminar
  5. el +1 es el truquito del sabor pues hombre. Que ignorancia ignorante.

    ResponderEliminar
    Respuestas
    1. eh!!! que pesado que sos con el muchacho de arriba! te lo pregunto bien! no podes contestar con amabilidad??

      Eliminar
  6. Excelente ejemplo. Es una muy buena manera de combinar la función BUSCARV con la función COINCIDIR.

    ResponderEliminar
  7. Y si tengo el numero pero quiero que busque la palabra, como le hago???

    ResponderEliminar

Creative Commons License
Esta obra está bajo una licencia de Creative Commons.
Excel, Excel 2003, Excel 2007 y el logo XL son marcas registradas de Microsoft Corporation.