26 de octubre de 2009

Evitar resultados #¡DIV/0!

Me pregunta una usuaria, a quien llamaremos Claudia Acosta, cómo hacer que Excel muestre un cero en lugar del código de error #¡DIV/0!

Siempre que intentamos realizar una división por cero, algo matemáticamente imposible, Excel nos alerta de esta situación con el resultado de error #¡DIV/0!

Claro que esto no se ve muy bien que digamos. Una forma de evitar este resultado y hacer que Excel nos devuelva otro resultado más "estético", (un cero), es valiéndonos de la función SI:

=SI(B2=0, 0, A2/B2)

Es decir, que si el divisor (B2 en este caso) es igual a cero, Excel debe devolver un cero. En caso contrario, devuelve la división A2/B2.

Existe otra manera, más corta, de evitar los resultados #¡DIV/0!, utilizando la fórmula:

=--SI(B2,A2/B2)

¿Cómo funciona? Debemos tomar en cuenta que para Excel, un cero equivale al valor lógico FALSO; mientras que cualquier otro valor equivale a un VERDADERO. Entonces, suponiendo que en A2 tengamos un 4 y en B2 un 2, la fórmula se convierte en:

=--SI(2, 4/2), lo que resulta en:
=--SI(VERDADERO,4/2)
=--4/2
=--2
=2

Pero, si en B2 tenemos un cero, entonces la fórmula resulta:

=--SI(0, 4/0)
=--SI(FALSO,4/0)

Cuando no establecemos el segundo argumento de SI (valor_si_falso), SI devuelve FALSO:

=--FALSO

Al aplicar un signo menos a este resultado, Excel lo convierte a su equivalente numérico, es decir, cero:

=0

Y para no cambiar de signo el resultado (en el primer caso), aplicamos un doble signo menos.

14 comentarios:

  1. MUCHAS gracias, me salvaste el trabajo para facultad. Saludos desde Uruguay.

    ResponderEliminar
  2. hay que bakano por fin aprendi
    gracias desde alemania

    ResponderEliminar
  3. Gracias me sirvio mucho el tip, saludos desde México.

    ResponderEliminar
  4. muchas gracias por el aporte me sirvio muchisimo. saludos desde Argentina

    ResponderEliminar
  5. gracias primo saludos de perú

    ResponderEliminar
  6. gracias por la información

    ResponderEliminar
  7. XD yo lo he hecho con =SI(ESERROR(A2/B2),0,A2/B2)...espero que les sea de utilidad...Saludos

    ResponderEliminar
  8. coooooooooooooool!!!

    ResponderEliminar
  9. hola estoy utilizando esta formula=BUSCARV(A6,julio!$A$7:$C$48,3,FALSO), pero en el resultado de busqueda al no encontrar el dato me da como resultado #n/a como lo quito sin quitar la formula y que me de cero como resultado.

    ResponderEliminar
  10. Anónimo:
    Se puede hacer aunque la fórmula quedaría un poco extensa:
    =SI(ESNOD(BUSCARV(A6,julio!$A$7:$C$48,3,FALSO)),0,BUSCARV(A6,julio!$A$7:$C$48,3,FALSO))

    ResponderEliminar
  11. Y SI SON VARIAS CELDAS LAS QUE TENGO QUE CONSIDERAR Y TODAS EN VALOR CERO?? NO ME SALE LA FORMULA,, ESTOY TRATANDO DE CONSIDERAR 5 CELDAS, PERO ME SIGUE ARROJANDO VALOR #¡DIV/0!

    ResponderEliminar
  12. HOLA, ESTOY UTILIZANDO ESTA FORMULA =B22*D22 PERO ME DA ERROR #N/A CUANDO NO HAY DATOS EN LAS CELDAS B22 Y D22. ME PODEIS INDICAR COMO QUITAR EL ERROR Y QUE LA CELDA APAREZCA EN BLANCO. GRACIAS, UN SALUDO A TODOS

    ResponderEliminar

Creative Commons License
Esta obra está bajo una licencia de Creative Commons.
Excel, Excel 2003, Excel 2007 y el logo XL son marcas registradas de Microsoft Corporation.