26 de octubre de 2009

Evitar resultados #¡DIV/0!

Me pregunta una usuaria, a quien llamaremos Claudia Acosta, cómo hacer que Excel muestre un cero en lugar del código de error #¡DIV/0!

Siempre que intentamos realizar una división por cero, algo matemáticamente imposible, Excel nos alerta de esta situación con el resultado de error #¡DIV/0!

Claro que esto no se ve muy bien que digamos. Una forma de evitar este resultado y hacer que Excel nos devuelva otro resultado más "estético", (un cero), es valiéndonos de la función SI:

=SI(B2=0, 0, A2/B2)

Es decir, que si el divisor (B2 en este caso) es igual a cero, Excel debe devolver un cero. En caso contrario, devuelve la división A2/B2.

Existe otra manera, más corta, de evitar los resultados #¡DIV/0!, utilizando la fórmula:

=--SI(B2,A2/B2)

¿Cómo funciona? Debemos tomar en cuenta que para Excel, un cero equivale al valor lógico FALSO; mientras que cualquier otro valor equivale a un VERDADERO. Entonces, suponiendo que en A2 tengamos un 4 y en B2 un 2, la fórmula se convierte en:

=--SI(2, 4/2), lo que resulta en:
=--SI(VERDADERO,4/2)
=--4/2
=--2
=2

Pero, si en B2 tenemos un cero, entonces la fórmula resulta:

=--SI(0, 4/0)
=--SI(FALSO,4/0)

Cuando no establecemos el segundo argumento de SI (valor_si_falso), SI devuelve FALSO:

=--FALSO

Al aplicar un signo menos a este resultado, Excel lo convierte a su equivalente numérico, es decir, cero:

=0

Y para no cambiar de signo el resultado (en el primer caso), aplicamos un doble signo menos.
Creative Commons License
Esta obra está bajo una licencia de Creative Commons.
Excel, Excel 2003, Excel 2007 y el logo XL son marcas registradas de Microsoft Corporation.