22 de noviembre de 2007

CONTAR.SI (y SUMAR.SI) Reloaded

CONTAR.SI nos retorna el número de celdas (o valores) que cumplen con determinado criterio dentro de determinado rango. La sintaxis es:

CONTAR.SI(rango, criterio)

Generalmente solo es usada en ejemplos como los siguientes:

=CONTAR.SI(A2:A30, 100);

=CONTAR.SI(B2:B20, "alguntexto");

=CONTAR.SI(C2:C40, "texto a" & "texto b"); o

=CONTAR.SI(D2:D50, C1)

Sin embargo, el argumento criterio es mucho más flexible. Podemos especificar expresiones lógicas, wildcards, fórmulas, valores lógicos, fechas... Estos son algunos ejemplos que muestran la potencia de la función al usar criterios complejos:

=CONTAR.SI(A2:A50, ">0") Devuelve el número de celdas con valores mayores a 0.

=CONTAR.SI(A2:A50, "<>1") Devuelve el número de celdas con valores distintos de 1.

=CONTAR.SI(A2:A50, "<" & B1) Devuelve el número de celdas con valores menores a la celda B1.

=CONTAR.SI(A2:A50, HOY()) Cuenta las celdas con fecha igual a la actual.

=CONTAR.SI(A2:A50, ">" & FECHA(2007,10,01)) Devuelve el número de celdas con fecha mayor (más reciente) a 01/10/2007. Ya hemos visto el uso de la función FECHA.

=CONTAR.SI(A2:A50, ">" & PROMEDIO(A2:A50)) Número de celdas con valores superiores al promedio del rango.

=CONTAR.SI(A2:A50, "?????") Da el número de celdas que contienen exactamente cinco caracteres.

=CONTAR.SI(A2:A50, "abc*") Da el número de celdas que empiezan con "abc". No es sensible a mayúsculas

=CONTAR.SI(A2:A50, "*abc*") Da el número de celdas que contienen "abc". No es sensible a mayúsculas.

=CONTAR.SI(A2:A50, "??z*") Devuelve el número de celdas cuyo tercer caracter es "z".

=CONTAR.SI(A2:A50, FALSO) Cuenta las celdas que contienen el valor lógico FALSO.

=CONTAR.SI(A2:A50, "#!REF!") Cuenta el número de celdas que contienen el valor de error #!REF!

Desde luego, podemos combinar las técnicas de los ejemplos anteriores. También, podemos usar este tipo de criterios en otras funciones, como SUMAR.SI.

Esta nota pensaba titularla "En el pedir está el dar".

16 comentarios:

  1. ME SIRVIO MUCHO MUCHAS GRACIAS

    ResponderEliminar
  2. ¡Ufff! Me sacaste de un lío con eso de los asteriscos. Lo había olvidado por completo.
    Mile grazie...

    ResponderEliminar
  3. Este blog ha sido eliminado por un administrador de blog.

    ResponderEliminar
  4. Gracias, esto me sacó de un lío al que le andaba dando vueltas, no se me habría ocurrido usar expresiones regulares :D

    ResponderEliminar
  5. As I Lay Dying Rulez!♥

    ResponderEliminar
  6. uyyyyyyyyyyy para mi no esta bien OKK hagan algo mejor!!!!!!!!!!!!! pz yo lo haria pero tiempo no tengo para perderlo!!!!!!!!!!!!

    ResponderEliminar
  7. llegaste aca buscando respuestas no dando soluciones agradece que alguien quiere darlas (y gratis) si no te sirve a ti, pues bueno, anda a otro lado,

    gracias hombre por todas las ayudas q publicas.
    suerte en todo!!

    ResponderEliminar
  8. Muy buen recurso
    Graciasssss

    ResponderEliminar
  9. una ayuda tengo una base de datos de alamcen con nombre del producto y codigo del producto quisiera saber como unirlos ya que uso un formato kardex y vaceo los datos al sistema por el nombre del producto... en fin agrego el nombre del producto y que me salga el codigo de este mismo. gracias por su pronta respuesta jorge1718@hotmmail.com

    ResponderEliminar
  10. malisimoooo,,,nmo entiendoooooo :$ u.U -.-

    ResponderEliminar
  11. YO DESEO CONTAR LOS NUMEROS DISTINTOS DE UNA MATRIZ DEACUERDO A UN CRITERIO X EJEMPLO:
    A B C D E F G
    CD 5 8 10 11 12 5
    AC 3 3 3 4 5 8
    FD 56 84 10 5 3 9
    CD 4 10 256 3 1 44
    HALLAR CUANTOS NUMEROS DISTINTOS TIENE CD.
    enviar a mi correo : solochris@hotmail.com.
    gracias

    ResponderEliminar
  12. hola,, llevaba días buscando,,, gracias por el post.
    Gonzalo

    ResponderEliminar
  13. Hola quiero contar las celdas q son menores q las celdas adyacentes. Por ejemplo, tengo en la columna "A" los valores: 1,2,3,4,5 y en la columna "B" los valores: 1,2,0,2,3. Quiero que cuente las 3 celdas de la columna B en las q la columna B es menor que la columna A. He probado con =CONTAR.SI(A1:A5;"<"&B1:B5) pero no sirve de nada. Muchas gracias.

    ResponderEliminar
    Respuestas
    1. Miguel:

      Utiliza esta fórmula matricial:
      =SUMA((B1:B5<A1:A5)*1)

      Nota: Tienes que aceptarla con Ctrl+Shift+Enter, ya que si solo le das Enter obtendrás el resultado ¡#VALOR! Verás que automáticamente Excel encerrará entre corchetes la fórmula, indicando así que se trata de una fórmula matricial.

      Saludos.

      Eliminar

Creative Commons License
Esta obra está bajo una licencia de Creative Commons.
Excel, Excel 2003, Excel 2007 y el logo XL son marcas registradas de Microsoft Corporation.