14 de febrero de 2008

Resolver una fórmula paso a paso

Frecuentemente, cuando trabajamos con fórmulas complejas, necesitamos tener un altísimo grado de concentración. El tratar de comprender o modificar una fórmula larga y compleja (sobre todo si no la hicimos nosotros), puede llegar a ser un proceso altamente frustrante, más aún si no utilizamos nombres. Consideremos la siguiente fórmula:

=SI(K9>=$B$69;$D$69;SI(K9<=$B$66;K9*BUSCARV(K9;$B$62:$C$69;2;1);(K9-1)*BUSCARV(K9;$B$62:$C$69;2;1)+1))

Por ello, es importante saber como ejecutar parcialmente una fórmula, es decir, resolviendo primero las subfórmulas interiores hasta llegar a la función más externa, para comprender más fácilmente que es lo que hace determinada fórmula.

Excel nos brinda dos opciones: la primera de ellas consiste en ejecutar las cálculos parciales directamente en la barra de fórmulas. Para ello, selecionamos con el cursor la fórmula exacta que queremos ejecutar (ni un paréntesis menos o más), en la barra de fórmulas, y presionamos F9. Siguiendo con nuestro ejemplo, seleccionaremos la fórmula más interna, es decir, el segundo BUSCARV. Desde la "B" hasta el penúltimo paréntesis de la fórmula general.

Después de presionar F9, vemos, en la barra de fórmulas, que el BUSCARV se ha convertido en su valor resultante. De acuerdo a los números que manejo en mi libro, el resultado de dicho BUSCARV es 1.68:

=SI(K9>=$B$69;$D$69;SI(K9<=$B$66;K9*BUSCARV(K9;$B$62:$C$69;2;1);(K9-1)*1.68+1))

Hacemos lo mismo con el primer BUSCARV, que en este caso es exactamente igual al segundo:

=SI(K9>=$B$69;$D$69;SI(K9<=$B$66;K9*1.68;(K9-1)*1.68+1))

Evidentemente la fórmula se vuelve un poco más manejable al ser más corta. Para terminar el proceso, debemos recordar presionar Esc para dejar la fórmula como al principio, ya que si presionamos Enter, las fórmulas se habrán convertido permenentemente en sus valores.

La segunda opción que tenemos es utilizar el Evaulador de fórmulas de Excel. Para acceder a él, ejecutamos, después de seleccionar la fórmula de interés, Herramientas - Auditoría de fórmulas - Evaluar fórmula. Lo que veremos es:
Vemos que Excel ha subrayado el primer valor o fórmula a evaluar (K9, siempre según el ejemplo). Aquí tenemos dos opciones. Si presionamos el botón Evaluar, Excel convertirá K9 a su valor resultante. En cambio, si presionamos Paso a paso para entrar, el cuadro mostrará la fórmula de K9 (en caso de que haya una fórmula en K9), y así sucesivamente hasta llegar a los valores de origen.

Esto es especialmente útil al momento de auditar un modelo.

Otra opción es agregar una o varias columnas auxiliares, cada una con la correspondiente subfórmula, tema de otra nota.

8 comentarios:

  1. como saco el total en un grafico de excel

    ResponderEliminar
  2. Anónimo:

    Tienes que agregar una columna con los totales en tu tabla de datos. Después, incluye esta columna en el gráfico.

    ResponderEliminar
  3. como hago la formula general en exel si me puedes ayudar

    ResponderEliminar
  4. si el promedio es mayor que8.6 tiene medalla
    me puden ayudar en esta formula no le entiendo ,puse formula ytodos me salen con medalla pero tengo reprobados

    ResponderEliminar
  5. me podrían ayudar con este ejercicio:
    nececito la formula para calcular la comision de cada vendedor de acuerdo a la venta que realiso
    mi correo vrve2005@gmail.com
    de antemano muchas gracias
    desde k. - hasta k.
    29000 - 30.000 5%
    30001 - 31.500 7%
    31501 - 40.000 9%

    Nombre - Ventas - kilos

    patricio donald $ 37.210.500 - 31.235
    pedro urdimales $ 28.640.360 - 29.610
    luis modoyuna $ 31.240.600 - 30.880
    marcelo mateo $ 42.150.900 - 29.640

    ResponderEliminar
  6. no entiendo y creo q vote por la 35

    ResponderEliminar
  7. Buen tip para resolver una fórmula paso a paso.

    ResponderEliminar
  8. Por favor, no puedo resolver el final de esta formula, gracias.



    Si el promedio es: Mayor a 10.5 aprobado, si es menor es Desaprobado, pero si es igual a 0 será Retirado

    ResponderEliminar

Creative Commons License
Esta obra está bajo una licencia de Creative Commons.
Excel, Excel 2003, Excel 2007 y el logo XL son marcas registradas de Microsoft Corporation.